Задать вопрос
27 мая, 08:24

В числовой последовательности из N произвольных целых чисел определить количество пар соседних элементов одинаковых по модулю, но разных по знаку.

+2
Ответы (1)
  1. 27 мая, 12:01
    0
    Uses crt;

    const n=10;

    var a:array [1 ... n] of integer;

    i, k: integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    a[i]:=random (100) ;

    writeln (a[i]) ;

    end;

    writeln;

    for i:=1 to n-1 do

    begin

    if abs (a[i]) = abs (a[i+1])

    then

    begin

    if ((a[i]>0) and (a[i+1]<0)) or ((a[i]0))

    then

    inc (k) ;

    end;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В числовой последовательности из N произвольных целых чисел определить количество пар соседних элементов одинаковых по модулю, но разных по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Решать в Pascal Найти наибольший элемент заданной целочисленной числовой последовательности. Входные данные: Во входном потоке в первой строке задано натуральное число N (N < = 1000) - количество элементов числовой последовательности.
Ответы (1)
В числовой последовательности из N произвольных вещественных чисел определить количество отрицательных элементов Это Паскаль, нужна программа)
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)