Задать вопрос
2 октября, 22:06

Определить, есть ли среди введенных натуральных чисел число k

+2
Ответы (1)
  1. 3 октября, 00:10
    0
    Var n, k: integer;

    begin

    write ('Введите целые числа n (n>0) и k: ') ;

    readln (n, k) ;

    assert (n>0) ;

    var Exists : = false;

    for var i : = 1 to n do

    begin

    write ('Введите ', i, ' целое число: ') ;

    var x : = ReadInteger;

    if x = k then

    begin

    Exists : = true;

    break;

    end;

    end;

    if Exists then

    writeln ('Число ', k, ' было введено')

    else writeln ('Число ', k, ' не было введено') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить, есть ли среди введенных натуральных чисел число k ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в Pascal Даны число A>0, числа x1, x2 ... Необходимо вводить числа x1, x2 ..., пока сумма модулей введенных чисел будет меньше A. Определить число введенных чисел. P.
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Помогите решить 2 задачи ... 1) Вывести на экран квадрат наибольшего из 2 введенных чисел? 2) Вывести на экран корень наибольшего из 3 введенных чисел?
Ответы (1)
Программа в pascal abc Вводится последовательность натуральных чисел. Признак конца ввода - число 0. Определить количество чисел кратных 2 и 3 и сумму всех введенных чисел.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)