Задать вопрос
23 октября, 09:20

Программа в pascal abc

Вводится последовательность натуральных чисел. Признак конца ввода - число 0. Определить количество чисел кратных 2 и 3 и сумму всех введенных чисел.

+3
Ответы (1)
  1. 23 октября, 11:17
    0
    Program pr;

    uses crt;

    Var k, a, sum:integer;

    Begin

    Writeln ('Vvedite posledovatelnost') ;

    k:=0;

    readln (a) ;

    sum:=a;

    While a0 do

    Begin

    readln (a) ;

    sum:=sum+a;

    if (a mod 2=0) and (a mod 3=0) then k:=k+1;

    end;

    Writeln ('k=', k) ;

    Writeln ('sum=', sum) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа в pascal abc Вводится последовательность натуральных чисел. Признак конца ввода - число 0. Определить количество чисел кратных 2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0.
Ответы (1)
Напишите программу в Pascal ABC, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9.
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)