Задать вопрос
15 марта, 03:16

Дана строка символов. удалить из нее первый знак препинания. Язык pascal.

+2
Ответы (1)
  1. 15 марта, 05:59
    0
    Const a:array[1 ... 4] of string = ('!','?','.',',') ;

    var s:string;

    i, j, k:integer;

    begin

    readln (s) ;

    for i:=1 to length (s) do begin

    for j:=1 to 4 do

    if s[i]=a[j] then k+=1;

    if k0 then break;

    end;

    delete (s, i, 1) ;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка символов. удалить из нее первый знак препинания. Язык pascal. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
Pascal ABC Дана строка, состоящая из маленьких английских букв и цифр. Удалить гласные буквы в конце строки от последней не гласной буквы или цифры (конечные гласные буквы). Вывести преобразованную строку и количество удаленных символов
Ответы (1)