Задать вопрос
26 декабря, 03:00

1. Написать программу для определения количества двузначных чисел в диапазоне от А до B, которые при делении на 6 дают остаток 2.

2. Найти сумму двузначных чисел в диапазоне от А до B, в которых первая цифра ровно в 2 раза больше второй.

+2
Ответы (1)
  1. 26 декабря, 05:37
    0
    1) var a, b, x:integer;

    begin

    write ('A: ') ;

    readln (a) ;

    write ('B: ') ;

    readln (b) ;

    for x:=a to b do

    begin

    if (x>=10) and (x<=99) then

    if x mod 6 = 2 then

    write (x,' ') ;

    end;

    end.

    2) var a, b, x, s : integer;

    begin

    write ('A: ') ;

    readln (a) ;

    write ('B: ') ;

    readln (b) ;

    for x:=a to b do

    if (x=21) or (x=42) or (x=63) or (x=84) then s:=s+x;

    write (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Написать программу для определения количества двузначных чисел в диапазоне от А до B, которые при делении на 6 дают остаток 2. 2. Найти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание 1. составьте программу вычисления количества двузначных чисел, которые кратны 2 и 3. задание 2. составьте программу, выводящую на экран все двузначные числа, у которых первая цифра в два раза больше второй. задание 3.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Написать программу в python: найдите все пятизначные числа, которые при делении на 133 дают в остатке 125, а при делении на 134 дают в остатке 111.
Ответы (1)
Составьте программу поиска трехзначных чисел которые при делении на 43 дают в остатке 41 а при делении на 47 дают в остатке 43
Ответы (1)
Найти все четырехзначные числа, которые при делении на 3 дают остаток 1, при делении на 4 - остаток 2, а сумма их цифр равна А. (А-вводится с клавиатуры)
Ответы (1)