Задать вопрос
24 мая, 10:14

Составьте программу поиска трехзначных чисел которые при делении на 43 дают в остатке 41 а при делении на 47 дают в остатке 43

+3
Ответы (1)
  1. 24 мая, 10:20
    0
    А нет таких чисел!

    var

    i:integer;

    begin

    for i:=1 to 10000 do / / по условиям задачи i:=1 to 999

    if (i mod 43 = 41) and (i mod 47 = 43) then

    writeln (i) ;

    end.

    Результаты вывода:

    1030

    3051

    5072

    7093

    9114

    Так что минимальное число, удовлетворяющее требованиям, 1030, но оно не трехзначное

    Вот более продвинутый алгоритм, делающий то же самое:

    var

    n43:integer;

    begin

    n43:=127;

    repeat

    n43:=n43+43;

    until (n43 mod 43 = 41) and (n43 mod 47 = 43) ; / / добавить and (n43<1000)

    writeln (n43)

    end.

    Результат вывода:

    1030
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу поиска трехзначных чисел которые при делении на 43 дают в остатке 41 а при делении на 47 дают в остатке 43 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в python: найдите все пятизначные числа, которые при делении на 133 дают в остатке 125, а при делении на 134 дают в остатке 111.
Ответы (1)
Логическое "ИЛИ" называется? 1. логическая связка для поиска всех других слов, кроме указанного в запросе 2. логическая связка для поиска по всем словам 3. логическая связка для поиска по любому из слов Ответ:
Ответы (1)
Паскаль найдите все пятизначные числа которые делении на 133 дают в остатке 125 а при делении на 134 в остатке 111
Ответы (1)
Задание 1. составьте программу вычисления количества двузначных чисел, которые кратны 2 и 3. задание 2. составьте программу, выводящую на экран все двузначные числа, у которых первая цифра в два раза больше второй. задание 3.
Ответы (1)
1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления суммы всех трехзначных чисел, кратных 17. (паскаль, тремя способами)
Ответы (1)