Задать вопрос
15 декабря, 09:57

Найти все четырехзначные числа, которые при делении на 3 дают остаток 1, при делении на 4 - остаток 2, а сумма их цифр равна А. (А-вводится с клавиатуры)

+4
Ответы (1)
  1. 15 декабря, 12:10
    0
    Function summ (a:integer) : integer;

    begin

    while (a0) do begin

    summ+=a mod 10;

    a:=a div 10;

    end;

    end;

    var i, a:integer;

    begin

    read (a) ;

    for i:=1000 to 9999 do

    if (i mod 3 = 1) and (i mod 4 = 2) and (a=summ (i)) then writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все четырехзначные числа, которые при делении на 3 дают остаток 1, при делении на 4 - остаток 2, а сумма их цифр равна А. (А-вводится ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
С клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестс клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестии
Ответы (1)
Дано натуральное число. Определить: а) сколько раз в нем встречается цифра а; б) количество его цифр, кратных z (значение z вводится с клавиатуры; z 2, 3, 4) ; в) сумму его цифр, больших a (значение a вводится с клавиатуры; 0 a 8) ;
Ответы (1)