Задать вопрос
6 мая, 03:03

Написать программу для решения следующей задачи: вычислить сумму и количество положительных элементов последовательности.

+5
Ответы (1)
  1. 6 мая, 04:35
    0
    Var

    sum, count, t : integer;

    begin

    sum : = 0; count : = 0;

    while not eoln do

    begin

    read (t) ;

    if t > 0 then

    begin

    sum : = sum + t;

    count : = count + 1;

    end;

    writeln (sum, ' ', count) ;

    end.

    если количество элементов указано

    var

    sum, count, t, n, i : integer;

    begin

    sum : = 0; count : = 0;

    read (n) ;

    for i : = 1 to n do

    begin

    read (t) ;

    if t > 0 then

    begin

    sum : = sum + t;

    count : = count + 1;

    end;

    writeln (sum, ' ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для решения следующей задачи: вычислить сумму и количество положительных элементов последовательности. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Написать программу на Pascal ABC. Дан целочисленный массив размера N. Вычислить сумму и количество положительных элементов, произведение и количество отрицательных элементов, произведение элементов до первого отрицательного.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)