Задать вопрос
25 января, 05:43

Написать программу на Pascal ABC. Дан целочисленный массив размера N. Вычислить сумму и количество положительных элементов,

произведение и количество отрицательных элементов, произведение элементов до

первого отрицательного. Отсортировать массив по возрастанию.

+1
Ответы (1)
  1. 25 января, 07:11
    0
    Var

    i, j, n, kolPol, kolOtr, sum, p, ch, k : integer;

    a : array of integer;

    begin

    readln (n) ;

    SetLength (a, n+1) ;

    randomize;

    for i: = 1 to n do

    a[i]: = random (100) - 50;

    sum: = 0; p: = 1;

    for i: = 1 to n do

    begin

    if a[i] > 0 then

    begin

    inc (kolPol) ;

    sum: = sum + a[i];

    end;

    if a[i] > 0 then

    begin

    inc (kolOtr) ;

    p: = p * a[i];

    end;

    end;

    writeln ('Количество положительных элементов: ', kolPol) ;

    writeln ('Сумма положительных элементов: ', sum) ;

    writeln ('Количество отрицательных элементов: ', kolOtr) ;

    writeln ('Произведение отрицательных элементов: ', p) ;

    i: = 1; p: = 1; ch: = 0;

    while (a[i] > = 0) and (i n+1) do

    begin

    p: = p * a[i];

    inc (ch) ;

    inc (i) ;

    end;

    if ch 0 then

    writeln ('Произведение до первого отрицательного элемента: ', p)

    else

    writeln ('Первый элемент массива отрицательный!') ;

    for i: = 1 to n-1 do

    for j: = 1 to n-i do

    if a[j] > a[j+1] then

    begin

    k: = a[j];

    a[j]: = a[j+1];

    a[j+1]: = k;

    end;

    writeln ('Массив отсортирован по возрастанию:') ;

    for i: = 1 to n do

    write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Pascal ABC. Дан целочисленный массив размера N. Вычислить сумму и количество положительных элементов, произведение и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)