Задать вопрос
6 мая, 00:30

Составьте программу вычисление тех значений элементов массива которые меньше 16

+1
Ответы (2)
  1. 6 мая, 01:03
    0
    Const m=200;

    var a: array[1 ... m] of integer;

    i, n: integer;

    begin

    write ('количество элементов массива: ') ;

    readln (n) ;

    randomize;

    write ('массив: ') ;

    for i:=1 to n do

    begin

    a[i]:=random (40) ;

    write (a[i],' ') ;

    end;

    writeln;

    write ('элементы, меньшие 16: ') ;

    for i:=1 to n do if a[i]<16 then

    write (a[i],' ') ;

    end.

    количество элементов массива: 15

    массив: 6 22 28 39 24 3 19 15 35 22 2 2 22 1 32

    элементы, меньшие 16: 6 3 15 2 2 1
  2. 6 мая, 03:13
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i, k:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (31) ;

    write (a[i]:4) ;

    end;

    writeln;

    k:=0;

    for i:=1 to n do

    if a[i]<16 then k:=k+1;

    writeln ('Количество элементов массива < 16 = ', k) ;

    end.

    Пример:

    Массив A:

    17 28 18 19 12 9 24 6 18 12

    Количество элементов массива < 16 = 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисление тех значений элементов массива которые меньше 16 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)