Задать вопрос
16 сентября, 18:40

4. Напишите программу, определяющую, верно ли, что при деление целого отрицательного числа а на целое положительное число b получается заданный остаток r или s. 5. Напшите программу, при выполнение которой выводится 1, если заданное число х принадлежит отрезку (a; b), или 0 в противном случае

+5
Ответы (1)
  1. 16 сентября, 19:03
    0
    1.

    var a, b, r, s:integer;

    begin

    write ('Введите числа a и b: ') ;

    readln (a, b) ;

    write ('Введите остатки r и s: ') ;

    readln (r, s) ;

    if (a mod b=r) or (a mod b=s) then writeln ('Да, верно')

    else writeln ('Нет, неверно')

    end.

    2.

    var a, b, x:real;

    begin

    write ('Введите числа a и b: ') ;

    readln (a, b) ;

    write ('Введите x: ') ;

    readln (x) ;

    if (a<=x) and (x<=b) then writeln (1)

    else writeln (0)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «4. Напишите программу, определяющую, верно ли, что при деление целого отрицательного числа а на целое положительное число b получается ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Написать программу которая определяет: если целое число M делится на целое число N, то на экране выводит часть деления, в противном случае выводится сообщение "M и N нацело не делиться" в pascal
Ответы (2)
Нужно написать программу в паскале. На вход поступает некое целое число икс (х). Х принадлежит промежутку (-30000; 30000) Если Х четное и делится на 5 то выводится соответствующая надпись. Если нет - надпись не выводится
Ответы (1)
напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае, если введенное число отрицательно. В противном случае на экран выводится сообщение ошибка
Ответы (2)