Задать вопрос
4 сентября, 09:45

Задача1: Треугольник существует только тогда, когда сумма любых двух его сторон больше третьей.

Дано: a, b, c - стороны предполагаемого треугольника. Требуется сравнить длину каждого отрезка с суммой двух других. Если хотя бы в одном случае отрезок окажется больше суммы двух других, то треугольника с такими сторонами не существует.

+3
Ответы (1)
  1. 4 сентября, 12:45
    0
    Uses crt;

    var a, b, c:integer;

    begin

    write ('Длины сторон: ') ;

    readln (a, b, c) ;

    if a < b+c then

    if b < a+c then

    if c < a+b then

    writeln ('Треугольник существует.')

    else

    writeln ('Треугольник не существует.')

    else

    writeln ('Треугольник не существует.')

    else

    writeln ('Треугольник не существует.') ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача1: Треугольник существует только тогда, когда сумма любых двух его сторон больше третьей. Дано: a, b, c - стороны предполагаемого ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача1: Составить программу, которая, если введенное число отрицательное, меняет его на противоположное. Задача2: Треугольник существует только тогда, когда сумма любых двух его сторон больше третьей.
Ответы (1)
Помогите составить алгоритм Даны 3 стороны треугольника A, B, C требуется сравнить длину каждой стороны с суммой 2 других. Если хотя бы в 1 случае сторона окажется больше суммы двух других, то треугольник не существует
Ответы (1)
Напишите программу для следующей задачи даны стороны предполагаемого треугольника a b c если такой треугольник существует Вычислите его периметр
Ответы (1)
Выходные данные Даны три натуральных числа a, b, c, записанные в отдельных строках. Определите, существует ли треугольник с такими сторонами (использовать неравенство треугольника Выходные данные Если треугольник существует, введите строку yes, если
Ответы (1)
Помогите решить (python 3.6) Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку YES, иначе выведите строку NO.
Ответы (1)