Задать вопрос
17 декабря, 22:11

Задача1: Составить программу, которая, если введенное число отрицательное, меняет его на противоположное.

Задача2: Треугольник существует только тогда, когда сумма любых двух его сторон больше третьей.

Дано: a, b, c - стороны предполагаемого треугольника. Требуется сравнить длину каждого отрезка с суммой двух других. Если хотя бы в одном случае отрезок окажется больше суммы двух других, то треугольника с такими сторонами не существует.

+2
Ответы (1)
  1. 17 декабря, 23:56
    0
    (в паскале) :

    program rwerwe;

    var

    a, b: integer;

    begin

    read (a) ;

    If a<0 then begin b=:a*-1; write (, b,) ; end else write (, a,)

    end.

    pr ...

    var

    a, b, c: real;

    begin

    read (a, b, c)

    If (ABS (a-b)
    else write ('треугольник существует')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача1: Составить программу, которая, если введенное число отрицательное, меняет его на противоположное. Задача2: Треугольник существует ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача1: Треугольник существует только тогда, когда сумма любых двух его сторон больше третьей. Дано: a, b, c - стороны предполагаемого треугольника. Требуется сравнить длину каждого отрезка с суммой двух других.
Ответы (1)
Помогите составить алгоритм Даны 3 стороны треугольника A, B, C требуется сравнить длину каждой стороны с суммой 2 других. Если хотя бы в 1 случае сторона окажется больше суммы двух других, то треугольник не существует
Ответы (1)
Напишите программу вывода на экран фразы "Число положительное", если введенное число положительное, и "Число отрицательное", если введенное число отрицательное.
Ответы (1)
1) Проверка условия и ветвление в алгоритме. Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран: а) удвоенное значение числа, если число положительное; б) абсолютное значение числа, если число отрицательное.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)