Задать вопрос
3 февраля, 15:41

Помогите составить алгоритм

Даны 3 стороны треугольника A, B, C требуется сравнить длину каждой стороны с суммой 2 других. Если хотя бы в 1 случае сторона окажется больше суммы двух других, то треугольник не существует

+4
Ответы (1)
  1. 3 февраля, 16:17
    0
    Var

    A, B, C:real;

    Begin

    Write ('A = ') ;

    ReadLn (A) ;

    Write ('B = ') ;

    ReadLn (B) ;

    Write ('C = ') ;

    ReadLn (C) ;

    if (A > B+C) or (B>A+C) or (C>B+A) then WriteLn ('Треугольника не существует')

    else WriteLn ('Треугольник существует')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить алгоритм Даны 3 стороны треугольника A, B, C требуется сравнить длину каждой стороны с суммой 2 других. Если хотя бы в 1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача1: Треугольник существует только тогда, когда сумма любых двух его сторон больше третьей. Дано: a, b, c - стороны предполагаемого треугольника. Требуется сравнить длину каждого отрезка с суммой двух других.
Ответы (1)
Задача1: Составить программу, которая, если введенное число отрицательное, меняет его на противоположное. Задача2: Треугольник существует только тогда, когда сумма любых двух его сторон больше третьей.
Ответы (1)
Умоляю помогите, мне нужно составить Алгоритм своего имени, зовут меня Нурлан Мне необходимо составить алгоритм каждой буквы: н, у, р, л, а, н Примерно алгоритм выглядит вот так - Поднять перо. Сместиться в точку. Опустить перо. Сместиться на вектор.
Ответы (1)
Если данное предложение представить в виде алгоритма то это будет: Если сделаешь уроки, то можешь пойти в кино, иначе сиди дома. А) Линейный алгоритм В) Алгоритм с ветвлением С) Комбинированный алгоритм D) Алгоритм с циклом
Ответы (1)
исключи из предложенных сочетаний слов те, которые невозможны в информатике: 1) линейный алгоритм 2) прямой алгоритм 3) циклический алгоритм 4) разветвляющийся алгоритм
Ответы (2)