Задать вопрос
9 ноября, 01:05

Дан массив из 5 элементов. Найти средне арифметическое всех элементов массива.

+5
Ответы (1)
  1. 9 ноября, 02:48
    0
    Program ArrayAverage;

    var a: Array [1 ... 5] of Integer;

    i: Integer;

    b: Real;

    Begin

    b : = 0;

    WriteLn ('Введите 5 целых чисел через пробел и нажмите Enter') ;

    For i : = 0 To 4 Do

    Begin

    Read (a[i]) ;

    End;

    For i : = 0 To 4 Do

    Begin

    b : = b + a[i];

    End;

    b : = b / 5;

    Write ('Среднее арифметичиское: ') ;

    WriteLn (b:10:2) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 5 элементов. Найти средне арифметическое всех элементов массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)