Задать вопрос
9 ноября, 03:36

Составить программу вычисления значения функции (при любом значении x) :

y=sin (3,2 + (sqr (1+x)) : (sqrt (sqr (5*x)))

Что не правильно?

Program N15b;

var x: integer; y:real;

begin

writeln ('Введите x') ;

readln (x) ;

y:=sin (3,2 + (sqrt (1+x)) : (sqrt (sqr (5*x))) ;

write (y) ;

end.

+3
Ответы (1)
  1. 9 ноября, 04:52
    0
    Во - первых: в задании не отмечено. что х целое (то есть не integer, a взять real)

    Деление в паскале обозначается как /, а не:

    Вместо 3,2 в программе пишем 3.2

    Если х=0, то в знаменателе окажется 0 и выражение не имеет смысла (это в программе не учтено)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления значения функции (при любом значении x) : y=sin (3,2 + (sqr (1+x)) : (sqrt (sqr (5*x))) Что не правильно? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы