Задать вопрос
3 декабря, 14:39

1. Дана последовательность из N

(2<=N<=100000) различных чисел. Выписать в возрастающем порядке все целые

числа находящиеся в интервале от минимального до максимального значения

элементов этой последовательности, которые не находятся в данной

последовательности.

Пример:

pos. in

pos. out

5

1 7 10 3

2

4 6 8 9

2. Дано натуральное число К.

Напечатать К-ую цифру последовательности 110100100010000100000 ..., в которой

выписаны подряд степени числа 10.

Пример:

dec. in

dec. out

4

1

3. Написать программу, которая

переводит десятичное натуральное число N (1<=N<=2147483648) в

шестнадцатеричную систему счисления. Входной файл: tohex. in, выходной:

tohex. out.

Пример:

Tohex. in

Tohex. out

35432

8A68

+2
Ответы (1)
  1. 3 декабря, 16:04
    0
    2) program 2;

    var

    k:integer;

    tmp:real;

    b:string;

    c:string;

    i:integer;

    begin

    k:=0; i:=0; tmp:=0;

    write (' Введите k:') ;

    read (k) ;

    repeat

    tmp:=exp (i*ln (10)) ;

    str (tmp:0:0, c) ;

    b:=b+c;

    i:=i+1;

    until length (b) > = k;

    c:=copy (b, k, 1) ;

    writeln (b) ;

    writeln ('k-я цифра:', c) ;

    readln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дана последовательность из N (2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Дана последовательность чисел. найти дана последовательность чисел. найти минимальное и максимальное число и вычислить их среднее арифметическое. в паскале
Ответы (1)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
укажите истинное высказывание (отметьте точкой) алгоритм всегда представляет собой некоторую последовательность вычислений алгоритм может представлять собой некоторую последовательность вычислений, а может последовательность действий
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)