Задать вопрос
11 декабря, 00:57

Помогите написать программу: треугольник задан длинами сторон a, b, c. Определите вид треугольника (тупоугольный, прямоугольный, остроугольный)

+4
Ответы (1)
  1. 11 декабря, 03:52
    0
    Var a, b, c:real;

    begin

    writeln ('Введите стороны треугольника') ;

    read (a, b, c) ;

    if ((a + b) > c) and ((a + c) > b) and ((b + c) > a) then

    begin

    if (sqr (a) + sqr (b) = sqr (c)) then writeln ('Это прямоугольный треугольник') ;

    if (sqr (a) + sqr (b) >sqr (c)) then writeln ('Это остроугольный треугольник') ;

    if (sqr (a) + sqr (b)
    end

    else writeln ('Такого треугольника не существует') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу: треугольник задан длинами сторон a, b, c. Определите вид треугольника (тупоугольный, прямоугольный, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программу надо составить в паскале: Составить программу определения вида треугольника по двум углам (прямоугольный, остроугольный, тупоугольный)
Ответы (1)
Даны натуральные числа a, b, c. Проверьте существует ли треугольник величины углов, которого в градусах при положительном результате установит вид треугольника: остроугольный, тупоугольный, прямоугольный? это в программе pascal
Ответы (2)
Даны три угла треугольника необходимо определить какой вид имеет треугольник прямоугольный, тупоугольный, остроугольный. Сделайте для паскаля, информатика
Ответы (1)
Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи использовать сложные логические условия. Программа должна иметь дружественный интерфейс.
Ответы (1)
Проверить возможность построения треугольника из отрезков заданной длины, узнать вид треугольника (прямоугольный, остроугольный, тупоугольный)
Ответы (1)