Задать вопрос
4 ноября, 20:54

Программу надо составить в паскале:

Составить программу определения вида треугольника по двум углам (прямоугольный, остроугольный, тупоугольный)

+2
Ответы (1)
  1. 4 ноября, 23:01
    0
    Var a, b, c: integer;

    begin

    write ('Угол A = ') ;

    readln (a) ;

    write ('Угол B = ') ;

    readln (b) ;

    if (a>0) and (b>0) and (a+b<180) then

    begin

    c:=180-a-b;

    writeln ('Угол C = ', c) ;

    if (a=90) or (b=90) or (c=90) then writeln ('Прямоугольный') ;

    if (a<90) and (b<90) and (c<90) then writeln ('Остроугольный') ;

    if (a>90) or (b>90) or (c>90) then writeln ('Тупоугольный') ;

    end

    else

    writeln ('Неверно заданы углы') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программу надо составить в паскале: Составить программу определения вида треугольника по двум углам (прямоугольный, остроугольный, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике