Задать вопрос
23 сентября, 15:31

Значения переменных X, Y, Z поменять местами

так, чтобы они оказались упорядоченными по возрастанию.

+5
Ответы (1)
  1. 23 сентября, 15:56
    0
    var a: array[1 ... 3] of integer;

    i, j, b: integer;

    begin

    writeln ('Vvedite 3 chisla') ;

    readln (a[1], a[2], a[3]) ;

    for i: = 1 to 2 do for j: = 1 to 3-i do if a[j]>a[j+1] then

    begin

    b: = a[j];

    a[j]: = a[j+1];

    a[j+1]: = b;

    end;

    for i: = 1 to 3 do write (a[i],' ') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Значения переменных X, Y, Z поменять местами так, чтобы они оказались упорядоченными по возрастанию. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Описать процедуру SortInc3 (A, B, C), меняющую содержимое переменных A, B, C таким образом, чтобы их значения оказались упорядоченными по возрастанию (A, B, C - вещественные параметры, являющиеся одновременно входными и выходными).
Ответы (1)
Написать код на языке С++ Вводят значения переменных X, Y. Поменять местами значения переменных так, чтобы в переменной Х появилось значение Y, а в Y-начальное значение Х
Ответы (1)
Значение переменных x, y, z поменять местами так, чтобы они были упорядочены по возрастанию. (написать программу в Паскале)
Ответы (1)
Антон сортирует по возрастанию список из 10 элементов: 6 12 3 4 9 2 10 11 7 5 Ему разрешается поменять местами любые два элемента, но за такой обмен ему придется отдать количество конфет, равное разности позиций обмениваемых элементов (позиции
Ответы (1)
1. Написать процедуру, меняющую значения двух переменных а и b местами. 2. Используя процедуру обмена значений двух переменных, упорядочьте по возрастанию переменные a, b, c.
Ответы (1)