Задать вопрос
13 августа, 11:14

Описать процедуру SortInc3 (A,

B, C), меняющую содержимое переменных A, B, C таким

образом, чтобы их значения оказались упорядоченными по возрастанию (A, B,

C - вещественные параметры, являющиеся одновременно входными и

выходными). С помощью этой процедуры упорядочить по возрастанию два данных

набора из трех чисел: (A1, B1, C1) и (A2, B2, C2).

+4
Ответы (1)
  1. 13 августа, 12:53
    0
    Procedure SwapInc (var a, b: real) ;

    begin

    a : = a + b;

    b : = a - b;

    a : = a - b;

    end;

    procedure SortInc3 (var a, b, c: real) ;

    begin

    if a > b then SwapInc (a, b) ;

    if b > c then SwapInc (b, c) ;

    if a > b then SwapInc (a, b) ;

    end;

    var a, b, c: real; i: integer;

    begin

    for i : = 1 to 2 do begin

    write ('a', i, '=') ; readln (a) ;

    write ('b', i, '=') ; readln (b) ;

    write ('c', i, '=') ; readln (c) ;

    SortInc3 (a, b, c) ;

    writeln (a, ' ', b, ' ', c) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Описать процедуру SortInc3 (A, B, C), меняющую содержимое переменных A, B, C таким образом, чтобы их значения оказались упорядоченными по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать процедуру, меняющую значения двух переменных а и b местами. 2. Используя процедуру обмена значений двух переменных, упорядочьте по возрастанию переменные a, b, c.
Ответы (1)
Информатика Даны два числа A и B. Вам нужно вычислить их сумму A+B. В этой задаче для работы с входными и выходными данными вы можете использовать и файлы и потоки на ваше усмотрение.
Ответы (1)
Значения переменных X, Y, Z поменять местами так, чтобы они оказались упорядоченными по возрастанию.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Очень нужна помощь! Помогите с задачками по С++ Написать функцию Minmax (A, B), которая записывает в переменную A наименьшее из значений A и B, а в переменную B - всего из этих значений (A и B - настоящие парамент, являющийся одновременно входными и
Ответы (1)