Задать вопрос
30 октября, 04:05

1. Написать

процедуру, меняющую значения двух переменных а и b местами.

2. Используя

процедуру обмена значений двух переменных, упорядочьте по возрастанию

переменные a, b, c.

+5
Ответы (1)
  1. 30 октября, 05:03
    0
    Procedure Swap (var a, b: object) ;

    var c: object : = a;

    begin

    a : = b;

    b : = c;

    end;

    var

    a, b, c: byte;

    begin

    readln (a, b, c) ;

    if (a > b) then Swap (a, b) ;

    if (b > c) then Swap (b, c) ;

    if (a > b) then Swap (a, b) ;

    if (b > c) then Swap (b, c) ;

    writeln (a, b, c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Написать процедуру, меняющую значения двух переменных а и b местами. 2. Используя процедуру обмена значений двух переменных, упорядочьте ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Описать процедуру SortInc3 (A, B, C), меняющую содержимое переменных A, B, C таким образом, чтобы их значения оказались упорядоченными по возрастанию (A, B, C - вещественные параметры, являющиеся одновременно входными и выходными).
Ответы (1)
Python Известны значения двух переменных, содержащие числа. Напишите программу, меняющую значения этих переменных между собой без использования третьей, буферной переменной.
Ответы (1)
Помощь по VBA! Даны две переменные вещественного типа: A, B. Перераспределить значения данных переменных так, чтобы в A оказалось меньшее из значений, а в B - большее. Вывести новые значения переменных A и B.
Ответы (1)
Задания. 1. Найти простейшую формулу от трёх переменных, принимающую значение 0 только на следующих наборах значений переменных: 7) А (0,0,0) = А (0,1,1) = А (1,0,1) = А (1,1,1) 2.
Ответы (1)
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)