Задать вопрос
17 апреля, 18:38

Значение переменных x, y, z поменять местами так, чтобы они были упорядочены по возрастанию. (написать программу в Паскале)

+3
Ответы (1)
  1. 17 апреля, 18:57
    0
    Var

    max, min, x, y, z:integer;

    begin

    readln (x, y, z) ;

    //Найдём максимум

    if (x>y) AND (x>z) then

    max:=x

    else

    if (y>x) AND (y>z) then

    max:=y

    else

    max:=z;

    //Найдём минимум

    if (x
    min:=x

    else

    if (y
    min:=y

    else

    min:=z;

    //Результат

    if (xmin) AND (xmax) then

    writeln (min,' ', x,' ', max)

    else

    if (ymin) AND (ymax) then

    writeln (min,' ', y,' ', max)

    else

    writeln (min,' ', z,' ', max)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Значение переменных x, y, z поменять местами так, чтобы они были упорядочены по возрастанию. (написать программу в Паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача для паскаля. Во входном файле имеется массив из 10 целых чисел. Первые 9 элементов упорядочены. В выходной файл вставить 10-й элемент так, чтобы все элементы массива были упорядочены.
Ответы (1)
Написать код на языке С++ Вводят значения переменных X, Y. Поменять местами значения переменных так, чтобы в переменной Х появилось значение Y, а в Y-начальное значение Х
Ответы (1)
Значения переменных X, Y, Z поменять местами так, чтобы они оказались упорядоченными по возрастанию.
Ответы (1)
Антон сортирует по возрастанию список из 10 элементов: 6 12 3 4 9 2 10 11 7 5 Ему разрешается поменять местами любые два элемента, но за такой обмен ему придется отдать количество конфет, равное разности позиций обмениваемых элементов (позиции
Ответы (1)
Даны величины переменных A, B, C, D. Требуется перенести значения переменных, следующим образом: в D сумму значений переменных С и В, в переменную А поместить значение из В, в В значение из С, в С значение из D решение в паскале
Ответы (1)