Задать вопрос
10 августа, 10:08

1. Составьте программу, которая

вычисляет среднюю плотность раствора (в кг/м3) по результатам измерения

плотности 7 проб (задаются в массиве констант: 1205, 1350, 1170, 1320, 1220,

1310, 1180).

+2
Ответы (2)
  1. 10 августа, 10:16
    0
    Program nikitos1515;

    const mas:array[1 ... 7] of integer = (1205, 1350, 1170, 1320, 1220, 1310, 1180) ;

    var i:integer;

    sredn:real;

    begin

    for i:=1 to 7 do

    sredn:=sredn+mas[i];

    sredn:=sredn/7;

    writeln ('Средняя плотность раствора = ', sredn) ;

    end.
  2. 10 августа, 10:42
    0
    Если решать с вашими константами:

    program test;

    uses crt;

    var a:array [1 ... 10] of integer;

    i: integer;

    rez:real;

    begin

    rez:=0;

    a[1]=1205; a[2]=1350; a[3]=1170; a[4]=1320; a[5]=1220; a[6]=1310; a[7]=1180;

    for i:=1 to 7 do

    rez:=rez+a[i];

    rez:=rez/7;

    write ('rez = ', rez) ;

    end.

    Но, я предлагаю, чтобы пользователь сам вводил 7 значений, это так:

    program test;

    uses crt;

    var a:array [1 ... 10] of integer;

    i: integer;

    rez:real;

    begin

    rez:=0;

    for i:=1 to 7 do

    read (a[i]) ;

    for i:=1 to 7 do

    rez:=rez+a[i];

    rez:=rez/7;

    write ('rez = ', rez) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Составьте программу, которая вычисляет среднюю плотность раствора (в кг/м3) по результатам измерения плотности 7 проб (задаются в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, которая вычисляет среднюю плотность раствора по результатам измерения плотности
Ответы (1)
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)
2. Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000. 3. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
1) составить программу, которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный 2-ая Составить программу, которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми язык паскаль
Ответы (1)