Задать вопрос
5 февраля, 18:25

Даны числа A и В. Вычислить произведение P = (3*A+1*B) · (4*A+2*B) · ...· (53*A+51*B).

Решение задачи в Паскале

+2
Ответы (1)
  1. 5 февраля, 18:54
    0
    var a, b, ml, i:longint;

    begin

    readln (a) ;

    readln (b) ;

    ml:=1;

    for i:=1 to 51 do begin

    ml:=ml * ((i+2) * a+i*b) ;

    / / можно тут добавить чтобы увидеть writeln (ml) ;

    end;

    writeln (ml) ;

    end.

    ну код будет выглядеть примерно так, но вместо обычного умножения должно быть длинное. Даже для маленьких значений не работает тк выходит за ограничения на логинт
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны числа A и В. Вычислить произведение P = (3*A+1*B) · (4*A+2*B) · ...· (53*A+51*B). Решение задачи в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача№1. Найти произведение цифр заданного трехзначного числа. Задача№2. Вычислить выражение y=cos (1) + cos (1/2) + cos (1/3) + ... + cos (1/n), где n вводить с клавиатуры. Задача№3. Даны действительные числа а1, а2 ... а n.
Ответы (1)
Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то вычислить площадь этого треугольника. Даны два действительных положительных числа х и у.
Ответы (1)
Хотя бы что-нибудь! Помогите решить задачи в паскале! Составить программу для: 1) Решения линейного уравнения ах + в = 0 (а, в ≠ 0).
Ответы (1)
Даны два числа. Вычислить их сумму. Если она превышает 1000, то вычислить и вывести квадрат. первого числа, иначе-вычислить и вывести куб второго числа
Ответы (1)
Написать программу в паскале 1. Вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d. 2, дано натуральное число n. Вычислить (1+1/12)  (1+1/22)  ... (1+1/n2). 3. Дано целое число А.
Ответы (1)