Задать вопрос
6 октября, 03:56

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.

+4
Ответы (1)
  1. 6 октября, 05:52
    0
    Program task1;

    var a, b, c, p, s : real;

    begin

    readln (a, b, c) ; if (a + b > c) and (a + c > b) and (b + c > a) then begin writeln ('Могут быть сторонами треугольника') ; p: = (a + b + c) / 2; s: = sqrt (p * (p - a) * (p - b) * (p - c)) ; writeln ('Площадь равна ', s) ; end else writeln ('Не могут быть сторонами треугольника') ;

    end.

    program task2;

    var a, b, c : real; d : integer;

    begin

    write ('Введите числа: ') ; readln (a, b) ; write ('Введите номер действия: ') ; readln (d) ; case d of 1: c: = a + b; 2: c: = a - b; 3: c: = a * b; 4: c: = a / b; end; writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то вычислить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны два действительных положительных числа x и y. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление).
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
Помогите! я ничего не понимаю! составьте программу! Арифметические действия над числами пронумерованы так: 1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление. Дан номер действия n и вещественные числа a, b (b0).
Ответы (2)
ЯП Java (Оператор варианта) Арифметические действия над числами пронумерованы следующим образом: 1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление. Дан номер действия N (целое число в диапазоне 1-4) и вещественные числа A и B (В не равно 0).
Ответы (1)
Используя числа 1, 3, 4, 6, арифметические операции (сложение, вычитание, умножение, деление) и скобки, получить число 24. Разрешается использовать только эти числа и только эти операции. Каждое число должно использоваться один и только один раз.
Ответы (1)