Задать вопрос
28 ноября, 04:52

1. Дано трехзначное число. Написать программу (Pascal), которая "переставляет" первую цифру числа на самое последнее место.

+2
Ответы (1)
  1. 28 ноября, 08:17
    0
    Uses crt;

    var a: integer;

    begin

    readln (a) ;

    a: = (a div 10 mod 10) * 100 + (a mod 10) * 10 + (a div 100) ;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дано трехзначное число. Написать программу (Pascal), которая "переставляет" первую цифру числа на самое последнее место. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Pascal ABC Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке. Входные данные Первая строка содержит размер массива N.
Ответы (1)