Задать вопрос
19 апреля, 15:11

В городе N-ске проходит конкурс на звание "Мистер большой живот". Побеждает тот, у кого объем талии больше всего. Помогите определить объем талии золотого и серебряного призера, если известно количество участников и объем талии каждого из них (все размеры талий различны)

Формат ввода N - кол-во участников Больше 3, меньше 100 А[1] объем талии первого участника А[N] объем талии N-ого участника (90<=А[N<=1000]).

Формпт вывода: два числа K1, K2 - объем талии золотого и серебрянного призера

Пример ввода 89 60 78 45 65 99 78

Пример вывода 99 89

+5
Ответы (1)
  1. 19 апреля, 16:58
    0
    Program gt;

    var n, i, j, l:integer;

    a:array[1 ... 1000]of integer;

    begin

    readln (n) ;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to n-1 do

    for j:=1 to n-1 do

    if (a[j]
    l:=a[j]; a[j]:=a[j+1];

    a[j+1]:=l;

    end;

    writeln (a[1],' ', a[2]) ;

    end.

    Я просто отсортировал массив по убыванию методом пузырка
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В городе N-ске проходит конкурс на звание "Мистер большой живот". Побеждает тот, у кого объем талии больше всего. Помогите определить объем ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
У белки было s1 орехов и s2 грибов. Она съела все грибы и s3 орехов. Сколько орехов у неё осталось? Формат ввода: s1 - количество орехов. s2 - количество грибов. s3 - количество съеденных орехов. Формат вывода: d - количество оставшихся орехов.
Ответы (1)
Нужно определить что в введеном числе 24 часовой формат или 12 часовой формат и составить код в с++ Задача такое: №1 Input (стандартный ввод) Output (вывод) 11:00 24-часовый формат 23:00 №2 Input (стандартный ввод) Output (вывод) 09:20 12-часовый
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Дано слово. Записать каждый символ по два раза. Формат ввода: s - слово Формат вывода: s1 - новое слово Пример ввода: дождь Пример вывода: ддоожжддьь
Ответы (1)
Напишите программу, которая будет читать любую строку, а затем выводить ее на экран. Формат ввода: s - строка Формат вывода: s - строка Пример ввода: I am a string. Пример вывода: I am a string.
Ответы (1)