Задать вопрос
18 марта, 10:02

Напишите программу, которая считывает с клавиатуры последовательность символов и выводит на экран:

а) количество считанных десятичных цифр;

б) количество четных цифр;

в) количество нечетных цифр;

+3
Ответы (1)
  1. 18 марта, 12:52
    0
    Var

    i, n, x, y, z:integer;

    s:string;

    begin

    readln (s) ;

    for i:=1 to length (s) do

    if (47
    begin

    n:=StrToInt (s[i]) ;

    case n of 0 ... 9:

    begin

    x:=x+1;

    if n mod 2=0 then y:=y+1 else z:=z+1

    end

    end

    end;

    writeln ('Число цифр: ', x,'; четных цифр: ', y,'; нечетных цифр: ', z)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая считывает с клавиатуры последовательность символов и выводит на экран: а) количество считанных десятичных цифр; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Напишите программу которая считывает с клавиатуры n чисел и затем и затем выводит на экран сумму и среднее арифметическое считанных чисел.
Ответы (1)
Напишите программу (Паскаль), которая считывает с клавиатуры последовательность символов и выводит на экран количество нечетных цифр: с
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Написать программы на языке С++ 1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
Ответы (1)