Задать вопрос
12 августа, 17:15

Дан целочисленный массив A (a1 ... an). Отсортировать массив по возрастанию, начиная с минимального элемента

+5
Ответы (1)
  1. 12 августа, 17:28
    0
    Const n=10;

    var

    a:array[1 ... n] of integer;

    i, i1, num:integer;

    begin

    for i:=1 to n do a[i]:=random (-100,100) ;

    for i:=1 to n-1 do begin

    for i1:=1 to n-i do begin

    if a[i1]>a[i1+1] then begin

    num:=a[i1];

    a[i1]:=a[i1+1];

    a[i1+1]:=num;

    end;

    end;

    end;

    for i:=1 to n do writeln (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив A (a1 ... an). Отсортировать массив по возрастанию, начиная с минимального элемента ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Паскаль! Дан целочисленный массив. Отсортировать массив по убыванию, начиная с максимального элемента
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)