Задать вопрос
14 августа, 07:21

Найти на отрезке (n; m) натуральное число, имеющие наибольшее количество делителей

+1
Ответы (1)
  1. 14 августа, 10:36
    0
    А на каком языке сделать?

    program test;

    var

    n, m: integer;

    max: integer;

    count: integer;

    number: integer;

    i: integer;

    function GetDividersCount (number: integer) : integer;

    var

    limit: integer;

    count: integer;

    i: integer;

    begin

    limit : = number div 2;

    count : = 0;

    for i : = 1 to limit do

    if number mod i = 0 then

    count : = count + 1;

    result : = count;

    end;

    begin

    write ('Enter range: ') ;

    read (n, m) ;

    max : = 0;

    for i : = n to m do

    begin

    count : = GetDividersCount (i) ;

    if max < count then

    begin

    max : = count;

    number : = i;

    end;

    end;

    writeln ('Result: ', number) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти на отрезке (n; m) натуральное число, имеющие наибольшее количество делителей ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма полиндродано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)
Найдите наименьшее натуральное число, у которого ровно 36 делителей (включая 1 и само число 36). Например, у числа 6 четыре делителя: 1, 2, 3, 6. В качестве ответа укажите одно натуральное число.
Ответы (2)