Задать вопрос
15 марта, 21:51

Найдите наименьшее натуральное число, у которого ровно 36 делителей (включая 1 и само число 36). Например, у числа 6 четыре делителя: 1, 2, 3, 6. В качестве ответа укажите одно натуральное число.

+4
Ответы (2)
  1. 15 марта, 22:50
    0
    Оптимизированно относительно предыдущего ответа.

    Так и не понятно причем тут 36 в качестве делителя, потому не использовалось

    var

    p, k, i: integer;

    begin

    p : = 2;

    while true do

    begin

    k : = 2;

    for i : = 2 to Floor (sqrt (p)) do

    if p mod i = 0 then

    if p div i = i then {случай полного квадрата}

    k : = k + 1

    else

    k : = k + 2;

    if k = 36 then break;

    p : = p + 1;

    end;

    writeln (p) ;

    end.
  2. 15 марта, 23:16
    0
    Var p, k, i:integer; f:boolean;

    begin

    f:=false;

    p:=36;

    while not f do

    begin

    p:=p+1;

    k:=2;

    for i:=2 to p div 2 do

    if p mod i = 0 then k:=k+1;

    f:=k=36;

    end;

    writeln (p) ;

    end.

    Результат:

    1260
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите наименьшее натуральное число, у которого ровно 36 делителей (включая 1 и само число 36). Например, у числа 6 четыре делителя: 1, 2, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найдите наименьшее натуральное число, у которого ровно 32 делителя (включая 1 и само число 32). Например, у числа 6 четыре делителя: 1, 2, 3, 6. В качестве ответа укажите одно натуральное число.
Ответы (1)
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов) Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число.
Ответы (1)
Дано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма полиндродано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма
Ответы (1)
Помогите, задача Паскаль! В промежутке от 1 до n вывести все числа, сумма делителей которых (включая 1 и не включая само число) равна самому числу.
Ответы (1)