Задать вопрос
12 мая, 14:25

Дана последовательность чисел 1 2 4 8 16. Какой номер будет у числа 1024.

На языке Паскаль

+5
Ответы (1)
  1. 12 мая, 17:07
    0
    Var

    a, b: integer;

    begin

    b : = 0;

    a : = 1;

    repeat

    b : = b + 1;

    a : = a * 2;

    until a = 1024;

    writeln (b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность чисел 1 2 4 8 16. Какой номер будет у числа 1024. На языке Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Выберите верное соотношение а) 1 кбайт = 1024 мбайт б) 1 тбайт=1024 гбайт с) 1 гбайт=1024 кбайт д) 1 мбайт=1024 байт
Ответы (1)
В порядке возрастания единицы измерения информации указаны в по- следовательности: 1) 1 килобайт, 2^20 байт, 1024 мегабайт 2) 2^10 килобайт, 1024 байт, 1 гигабайт 3) 2^10 байт, 1 терабайт, 1024 мегабайт 4) 2^20 байт, 1 мегабайт, 1024 килобайт
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)