Задать вопрос
9 апреля, 20:26

Дано целое число n>2. Получите все простые числа из диапазона [2, n].

+2
Ответы (2)
  1. 9 апреля, 20:52
    0
    public int gcd (int x, int y) { if (y = = 0) return x; if (y = = x) Concole. Write (x + " ";) / / выводим простое число return gcd (y, x % y) ; } / / вызов gcd (2, n) ;
  2. 9 апреля, 21:25
    0
    Var a, b, k, j: integer; begin readln (j) ; a : = 1; b : = 1; while (j > a) do begin k : = b; b : = b + a; a : = k; end; writeln (a) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое число n>2. Получите все простые числа из диапазона [2, n]. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Паскаль. 1 дано целое число N. Вычислить среднее арифметическое всех чисел из диапазона от 1 до N. 2 дано целое число N. Вывести на экран все нечётные числа из диапахона от 1 до N. Вычислить их сумму.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Целое число было выбрано наугад из заданного диапазона чисел. Сообщение о выборе числа из какого диапазона несет наименьшее количество информации: a) от 12 до 76 b) от 100 до 133 c) от - 17 до 25 d) от - 32 до 0 e) от 12 до 34
Ответы (1)
Дан массив натуральных чисел заданных случайным образом из диапазона от 0 до 20 и число х из этого же диапазона. Длина массива равна N. Вставить число х после первого элемента кратного пяти
Ответы (2)