Задать вопрос
10 ноября, 07:23

Дано целое число Х и натуральное N. Составить алгоритм вычисления значения Х в степени N. Выполнить трассировку, при Х=2, N=3

+1
Ответы (1)
  1. 10 ноября, 10:13
    0
    Var X, N, i:integer;

    S:real;

    begin

    write ('Введите число X: ') ;

    readln (X) ;

    write ('Введите степень N: ') ;

    readln (N) ;

    S: = 1;

    for i:=1 to N do

    S: = S*X;

    writeln ('Ответ: ', S:0:0) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое число Х и натуральное N. Составить алгоритм вычисления значения Х в степени N. Выполнить трассировку, при Х=2, N=3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите на АЯ алгоритм сложение 2-х простых дробей (без сокращения дроби) 2) Напишите на АЯ алгоритм вычисления y по формуле y = (1-х^2+5x^4) при х=
Ответы (1)
1) Алгоритм вычисления значения функции F (n), где n - натуральное число, задан следующими соотношениями: F (1) = 1, F (2) = 1 F (n) = F (n-2) * (n-1) + 2, при n > 2 Чему равно значение функции F (8) ? В ответе запишите только натуральное число.
Ответы (1)
Напишите программы на Паскале, используя цикл "Пока". 1) Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. 2) Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N.
Ответы (1)
Составить алгоритм вычисления суммы ряда натуральных чисел от 1 до N. Выполнить трассировку для N=4
Ответы (1)
Дано целое число X и натуральное N. Составьте алгоритм вычисления X^N. Проверьте алгоритм трассировкой. Напишите программу на Паскале.
Ответы (1)