Задать вопрос
17 января, 20:24

написать программу на Паскале: А) Условие задачи №1: если введенное целое число является трехзначным, то удалить из него среднюю цифру; если число двухзначное, то удвоить крайние цифры; иначе - выдать сообщение "Ошибка ввода".

+5
Ответы (1)
  1. 17 января, 21:37
    0
    var

    i, x, n:integer;

    s1, s2, s3:string;

    begin

    write ('Введите число: ') ;

    readln (x) ; if (x >999) or (x<10) then write ('Ошибка ввода!') ;

    if (x99) then begin

    str (x, s1) ;

    delete (s1,2,1) ;

    write (s1) ;

    end;

    if (x9) then begin

    n: = x div 10 * 2;

    x:=x mod 10 * 2;

    str (n, s1) ;

    str (x, s2) ;

    s3:=s1+s2;

    write (s3) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу на Паскале: А) Условие задачи №1: если введенное целое число является трехзначным, то удалить из него среднюю цифру; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Удвоить трехзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае. Если введенное число не трехзначное, вывести сообщение об ошибке.
Ответы (1)
Если целое число М, введенное с клавиатуры, делится на целое число Н, введенное с клавиатуры, с остатком равным 2, то вывести на экран целую часть от деления М на Н, в противном случае - сообщение "при делении ... на ... остаток не равен 2"
Ответы (1)
Дано трехзначное целое число. Найти сумму его цифр и выдать это число в "перевернутом" виде (было 123, выдать 321) Примечание. n1 - 1-я цифра исходного числа, n2 - вторая, n3 - третья (решение задачи в паскале)
Ответы (1)