Задать вопрос
10 января, 23:10

написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после перестановки цифр. В противном случае, вывести выбранное ПК число

+2
Ответы (1)
  1. 10 января, 23:52
    0
    var x, x1, x2, x3: integer; / / x1 - 1 число, х2 - 2 число, х3 - 3 число

    begin

    randomize;

    x:=random (1000) + 10;

    if x div 100 >0 then begin x1:=x div 100;

    x2: = (x mod 100) div 10;

    x3: = (x mod 100) mod 10;

    writeln (x,', ', x3, x2, x1) ;

    end

    else writeln (x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Дан массив А (м), м меньше или равно 20. Вывести на печать сумму элементов массива. если она превосходит число 50, в противном случае вывести в печать исходный массив.
Ответы (1)
Pascal. Даны массивы A (m) и Y (m), m≤16. Найти сумму S : S=A1Ym+A2Ym-1 + ... + AmY1. Если S
Ответы (1)
Даны два числа - С иК. Вывести на печать их разность, если целая часть их отношения равна нулю, в противном случае вывести на печать их сумму.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)