Задать вопрос
28 мая, 08:17

Дан массив А (м), м меньше или равно 20. Вывести на печать сумму элементов массива. если она превосходит число 50, в противном случае вывести в печать исходный массив.

+2
Ответы (1)
  1. 28 мая, 09:35
    0
    Program summa;

    Uses crt;

    Const m=20;

    Var a:array[1 ... m] of integer;

    i, s:integer;

    Begin

    For i:=1 to m do

    a[i]:=random (101) - 50;

    For i:=1 to m do

    s:=s+a[i];

    If s>50 then writeln ('Сумма = ', s) else

    for i: = 1 to m do

    Writeln ('Элемент массива №', i,' равен ', a[i]) ;

    End.

    или

    Program summa;

    Uses crt;

    Const m=20;

    Var a:array[1 ... m] of integer;

    i, s:integer;

    Begin

    For i:=1 to m do

    Readln (a[i]) ;

    clrscr;

    For i:=1 to m do

    s:=s+a[i];

    If s>50 then writeln ('Сумма = ', s) else

    for i: = 1 to m do

    Writeln ('Элемент массива №', i,' равен ', a[i]) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив А (м), м меньше или равно 20. Вывести на печать сумму элементов массива. если она превосходит число 50, в противном случае ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)