Задать вопрос
27 ноября, 04:46

Автоморфные числа

Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата.

Например 25²=625. Напишите программу,

которая находит все автоморфные числа на отрезке [a, b ].

Входные данные

Входная строка содержит два натуральных

числа - значения a и b, разделённых пробелами. Гарантируется, что a ≤ b.

Выходные данные

Программа должна вывести в одну строчку все

автоморфные числа на отрезке [ a, b ], разделив их пробелами. Если таких чисел нет,

программа должна вывести число - 1.

Примеры

входные данные

20 100

выходные данные

25 76

+5
Ответы (1)
  1. 27 ноября, 05:12
    0
    Var a, b, a1, i, k, x, q:integer;

    begin

    readln (a, b) ;

    a1:=a;

    k:=0;

    while a0 do

    begin

    a:=a div 10;

    k:=k+1;

    end;

    x:=1;

    for i:=1 to k do

    x:=x*10;

    q:=-1;

    for i:=a1 to b do

    if i = ((i*i) mod x) then

    begin

    write (i, ' ') ;

    q:=i;

    end;

    if q=-1 then write (q) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Автоморфные числа Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например 25²=625. Напишите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу в паскаль! Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в K - ю степень (где K - количество цифр в числе) равна самому числу. Например, 153 = 1 3 + 5 3 + 3 3.
Ответы (1)
Напишите программу на Python Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например, 252 = 625.
Ответы (1)
Натуральное число называется автоморфным, если оно равно последним числам своего квадрата. Например 25^2 = 625. Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)