Задать вопрос
18 февраля, 06:43

Напишите программу на Python

Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например, 252 = 625. Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

Пример:

Введите N:

1000

1*1=1

5*5=25

6*6=36

25*25=625

76*76=5776

+5
Ответы (1)
  1. 18 февраля, 07:24
    0
    Только Паскаль или C + + (Пс на Кибер форуме попроси перевести)

    Var

    i, N : integer;

    Begin

    Write ('N = ') ; Readln (n) ;

    For I:=1 to N do

    Proverka (i) ;

    Writeln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на Python Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например, 252 = ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автоморфные числа Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например 25²=625. Напишите программу, которая находит все автоморфные числа на отрезке [a, b ].
Ответы (1)
Натуральное число называется автоморфным, если оно равно последним числам своего квадрата. Например 25^2 = 625. Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.
Ответы (1)
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234) 2) Автоморфным называется число, цифры которого совпадают с последними цифрами его квадрата.
Ответы (1)