Задать вопрос
10 февраля, 03:14

Натуральное число называется автоморфным, если оно равно последним числам своего квадрата. Например 25^2 = 625. Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

+4
Ответы (1)
  1. 10 февраля, 04:06
    0
    Var

    N, A:integer;

    B:longint;

    k:boolean;

    Begin

    Write ('N = ') ;

    ReadLn (N) ;

    For N: = 1 to N do

    Begin

    k:=true;

    A:=N;

    B:=A*A;

    While A0 do

    Begin

    if (A mod 10 B mod 10) then k:=false;

    A: = A div 10;

    B: = B div 10;

    End;

    if k then Write (N,' ') ;

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Натуральное число называется автоморфным, если оно равно последним числам своего квадрата. Например 25^2 = 625. Напишите программу, которая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автоморфные числа Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например 25²=625. Напишите программу, которая находит все автоморфные числа на отрезке [a, b ].
Ответы (1)
Напишите программу на Python Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например, 252 = 625.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234) 2) Автоморфным называется число, цифры которого совпадают с последними цифрами его квадрата.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)