Задать вопрос
7 марта, 14:32

Напишите программу в паскаль!

Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в K - ю степень (где K - количество цифр в числе) равна самому числу. Например,

153 = 1 3 + 5 3 + 3 3.

Напишите программу, которая находит все числа Армстронга на отрезке [ a, b ].

Входные данные

Входная строка содержит два натуральных числа - значения a и b, разделённых пробелами. Гарантируется, что a ≤ b.

Выходные данные

Программа должна вывести в одну строчку все числа Армстронга на отрезке [ a, b ], разделив их пробелами. Если таких чисел нет, программа должна вывести число - 1.

+1
Ответы (1)
  1. 7 марта, 17:51
    0
    Program Amstrong;

    var

    a, b: integer;

    i, j, k,

    ci,

    si, mi,

    errkod: integer;

    sti: string;

    flag: Boolean;

    begin

    Readln (a, b) ;

    flag:=false;

    for i:=a to b do

    begin

    str (i, sti) ;

    si:=0;

    for j:=1 to Length (sti) do

    begin

    val (sti[j], mi, errkod) ;

    ci:=1;

    for k:=1 to Length (sti) do

    ci:=ci*mi;

    si:=si+ci;

    end;

    if si=i then

    begin

    write (si,' ') ;

    flag:=true

    end;

    end;

    if not flag then write (-1) ;

    Readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в паскаль! Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в K - ю степень (где K - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Автоморфные числа Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например 25²=625. Напишите программу, которая находит все автоморфные числа на отрезке [a, b ].
Ответы (1)
Программа в C++ Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел. Входные данные Входная строка содержит единственное число - требуемое количество чисел N.
Ответы (1)
Мальчик коля хорошо считал, поэтому для составления пароля он использовал числа армстронга. (Натуральное десятичное N - значное число называется числом армстронга, если сумма его цифр возведённых в степень N, равна самому числу.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)