Задать вопрос
2 февраля, 14:45

Дан массив A (m), m ≤ 20. Найти сумму S его положительных элементов.

Все отрицательные элементы удвоить.

Вывести на печать исходный массив, переформированный массив и число S.

+5
Ответы (1)
  1. 2 февраля, 16:34
    0
    For i:=1 to m do

    begin

    if (-a[m]a[m]) then s:=s+1;

    else a[m]:=a[m]*2;

    writeln (a[m],' ') ;

    end;

    writeln (s) ;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив A (m), m ≤ 20. Найти сумму S его положительных элементов. Все отрицательные элементы удвоить. Вывести на печать исходный массив, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Дан массив А (м), м меньше или равно 20. Вывести на печать сумму элементов массива. если она превосходит число 50, в противном случае вывести в печать исходный массив.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)