Задать вопрос
21 июня, 10:30

Проверить находиться ли в массиве данное число. (Паскаль)

+3
Ответы (2)
  1. 21 июня, 11:18
    0
    Var a, b, i, n:integer;

    s:array [1 ... 10000] of integer;

    begin

    read (n) ; for i:=1 to n do

    read (s[i]) ;

    read (b) ;

    for i:=1 to n do

    if s[i]=b then inc (a) ;

    if a0 then write ('Встречается') else write ('Не встречается') ;

    end.

    P. S. Надеюсь на благодарность и лучший ответ.
  2. 21 июня, 14:22
    0
    Uses crt;

    const N=10;

    var a:array [1 ... N] of integer;

    x, k, z:integer;

    begin

    k:=0;

    for x:=1 to N do

    begin

    write ('a[', x,']:') ; readln (a[x]) ;

    end;

    write ('Введите число:') ; readln (k) ;

    for x:=1 to N do

    if a[x]=k then inc (z) ;

    if z>0 then writeln ('Число ', k,' встречается в массиве ', z,' раз (-а).')

    else writeln ('Число ', k,' не встречается в массиве') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Проверить находиться ли в массиве данное число. (Паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
2. В массиве Z[1 ... N] определить сумму нечетных чисел от последнего нулевого значения до Z[N] и среднее арифметическое четных чисел, находящихся в массиве до последнего нуля. Если нулей в массиве нет, то рассортировать все числа по убыванию.
Ответы (1)
Паскаль Формат входных данных Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Формат выходных данных Необходимо вывести значение наибольшего элемента в массиве.
Ответы (1)
На Паскаль 1. С клавиатуры вводится число. Осуществить линейный поиск элемента в массиве. Вывести номер элемента, равного данному, либо сообщение о том, что такого элемента в массиве нет. 2.
Ответы (1)