Задать вопрос
31 мая, 08:45

Напишите прогу в паскале

Вводится последовательно 15 чисел найти самое большое положительно кратное 3

+4
Ответы (1)
  1. 31 мая, 11:07
    0
    Var i, a, b, max: integer;

    begin max : = - maxint; b : = 0; for i : = 1 to 15 do begin Write ('Введите число: ') ; Readln (a) ; if (a mod 3 = 0) then if (a > max) then max : = a; end; Write ('Самое большое число кратное 3 = ', max) ; end. Если нигде не ошибся, то должно работать именно так
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите прогу в паскале Вводится последовательно 15 чисел найти самое большое положительно кратное 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Вводится 10 чисел. Найти сумму положительных двузначных чисел. 2. Вводится текст. Конец ввода точка. Найти количество букв "Г" и "г". Помогите решить задачи в паскале
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)