Задать вопрос
21 марта, 12:31

Дано натуральное число. Поменять первую местами и последнюю цифры (1234->4231)

+2
Ответы (1)
  1. 21 марта, 15:06
    0
    Var a:string;

    p:char;

    begin

    readln (a) ;

    p:=a[1];

    a[1]:=a[length (a) ];

    a[length (a) ]:=p;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число. Поменять первую местами и последнюю цифры (1234->4231) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после
Ответы (1)
Дано 4 значное число, поменять местами первую и последнюю цифру. Программирование, составить в Паскале
Ответы (1)
Дано число. Поменять первую и последнюю цифру местами, если они не равны друг другу. Паскаль)
Ответы (1)
Построить алгоритм. С клавиатуры вводится трехзначное число А. поменять местами первую и последнюю цифры в этом числе.
Ответы (1)