Задать вопрос
4 мая, 18:49

Дано 4 значное число, поменять местами первую и последнюю цифру. Программирование, составить в Паскале

+3
Ответы (1)
  1. 4 мая, 21:12
    0
    Если надо вывести получившееся число без ведущих нулей (т. е. 1000 превратить в 1), то можно так:

    var n: integer;

    begin

    readln (n) ;

    writeln (1000 * (n mod 10) + (n - (n mod 10) - 1000 * (n div 1000)) + n div 1000)

    end.

    Если надо сохранять ведущие нули, то можно, например, считать число посимвольно.

    var i: integer;

    c: array[1 ... 4] of char;

    t: char;

    begin

    for i : = 1 to 4 do

    read (c[i]) ;

    t : = c[1]; c[1] : = c[4]; c[4] : = t;

    for i : = 1 to 4 do

    write (c[i])

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 4 значное число, поменять местами первую и последнюю цифру. Программирование, составить в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи по информатике (на уровне знаний 7 класса) с помощю PascalABC 1. Дано 2 числа найти модуль разности этих чисел увеличенный в 5 раз. 2. Дано 4 значное число поменять местами 1 и 2 цифру местами 3.
Ответы (1)
написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после
Ответы (1)
Дано число. Поменять первую и последнюю цифру местами, если они не равны друг другу. Паскаль)
Ответы (1)
Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось 237. Найти число x. Решить на Паскале
Ответы (1)
Поменять местами первую и последнюю цифру в 4-х значном числе на pascal ABC
Ответы (1)