Задать вопрос
30 ноября, 02:29

Поменять местами первую и последнюю цифру в 4-х значном числе на pascal ABC

+4
Ответы (1)
  1. 30 ноября, 06:27
    0
    Var a, b:integer;

    begin

    readln (a) ;

    b:=abs (a) ;

    b: = (b mod 10*1000) + (b div 10 mod 100*10) + (b div 1000) ;

    if a>0 then a:=b else a:=-b;

    writeln (a) ;

    end.

    Пример:

    4567

    7564
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Поменять местами первую и последнюю цифру в 4-х значном числе на pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Даны 2 числа в двоичном виде. В первом числе поменять местами старшую и младшую части числа. Во втором - 1-ый и 4-ый разряды поменять местами с 3-м и 7-мым разрядами соответственно. Результаты логически сложить и умножить на 4.
Ответы (1)
Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (ABC Pascal)
Ответы (1)
В трехзначном числе x зачеркнули его последнюю цифру. когда в оставшимся двузначном числе переставили цифры, а затем приписали к ним слева последнюю цифру числа x, то получилось число n.
Ответы (1)
Помогите сделать задание в С++ В трехзначном числе x зачеркнули его последнюю цифру. Когда в оставшемся двузначном числе переставили цифры, а затем приписали к ним слева последнюю цифру числа x, то получилось число n.
Ответы (1)