Задать вопрос
10 ноября, 18:55

Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (ABC Pascal)

+5
Ответы (1)
  1. 10 ноября, 19:07
    0
    Var

    a, chislo, t:longint;

    c, nov, posl:integer;

    begin

    readln (a) ;

    posl:=a mod 10;

    chislo:=a;

    t:=1;

    repeat

    a:=a div 10;

    t:=t*10;

    until a<10;

    chislo:=chislo mod t;

    chislo:=posl*t+chislo-posl+a;

    writeln (chislo) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (ABC Pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу по "Из трехзначного числа Х вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа Х, то получилось число 237. Найти число Х." Язык Pascal. Заранее благодарна.
Ответы (1)
Помогите написать программу на Pascal Из трехзначного числа X вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа X. То получилось число N.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось 237. Найти число x. Решить на Паскале
Ответы (1)
1. Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось число 237. Найти число x.
Ответы (1)