Задать вопрос
17 сентября, 22:23

Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось 237. Найти число x. Решить на Паскале

+2
Ответы (1)
  1. 17 сентября, 23:53
    0
    var chastnoe, cifra, x, y:integer;

    begin

    y:=237;

    cifra: = (y div 100) ; / / получаем первую цифру числа 237

    chastnoe: = (y mod 100) ; / / находим число получившееся после деления

    x:=chastnoe*10+cifra; //находим число Х

    writeln (x) ; / / выводим

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу по "Из трехзначного числа Х вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа Х, то получилось число 237. Найти число Х." Язык Pascal. Заранее благодарна.
Ответы (1)
1. Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось число 237. Найти число x.
Ответы (1)
Из трехзначного числа Х вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа Х, то получилось число 237. Найти число Х
Ответы (2)
Помогите написать программу на Pascal Из трехзначного числа X вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа X. То получилось число N.
Ответы (1)
В трехзначном числе x зачеркнули его последнюю цифру. когда в оставшимся двузначном числе переставили цифры, а затем приписали к ним слева последнюю цифру числа x, то получилось число n.
Ответы (1)